libreboot

Unnamed repository; edit this file 'description' to name the repository.
Log | Files | Refs | README

commit 1335225c0c0c44eb2db834345b409bfe4e82692b
parent b6730357e23d112d98400335d034110b8c3c3626
Author: Leah Woods <info@minifree.org>
Date:   Fri, 20 May 2016 01:20:43 +0100

seabios board configs: update to fix broken  automated build

Diffstat:
resources/libreboot/config/seabios/kcma-d8/config | 71+++++++++++++++++++++++++++++++----------------------------------------
resources/libreboot/config/seabios/kgpe-d16/config | 71+++++++++++++++++++++++++++++++----------------------------------------
2 files changed, 62 insertions(+), 80 deletions(-)

diff --git a/resources/libreboot/config/seabios/kcma-d8/config b/resources/libreboot/config/seabios/kcma-d8/config @@ -166,16 +166,16 @@ CONFIG_RAMTOP=0x400000 CONFIG_CACHE_ROM_SIZE_OVERRIDE=0 CONFIG_CBFS_SIZE=0x200000 # CONFIG_POST_DEVICE is not set -CONFIG_USBDEBUG_HCD_INDEX=0 CONFIG_BOOT_MEDIA_SPI_BUS=0 CONFIG_TTYS0_LCS=3 +CONFIG_CONSOLE_POST=y +CONFIG_DRIVERS_UART_8250IO=y CONFIG_UDELAY_LAPIC_FIXED_FSB=200 CONFIG_CPU_ADDR_BITS=48 CONFIG_DEFAULT_CONSOLE_LOGLEVEL=8 # CONFIG_USBDEBUG is not set CONFIG_MAINBOARD_VERSION="1.0" CONFIG_DRIVERS_PS2_KEYBOARD=y -CONFIG_DRIVERS_UART_8250IO=y # CONFIG_NO_POST is not set CONFIG_BOARD_ROMSIZE_KB_2048=y # CONFIG_COREBOOT_ROMSIZE_KB_64 is not set @@ -211,6 +211,7 @@ CONFIG_BOOTBLOCK_SOUTHBRIDGE_INIT="southbridge/amd/sb700/bootblock.c" CONFIG_TTYS0_BASE=0x3f8 CONFIG_EHCI_BAR=0xfef00000 CONFIG_HEAP_SIZE=0xc0000 +CONFIG_CONSOLE_CBMEM=y # CONFIG_SOC_MARVELL_ARMADA38X is not set # CONFIG_SOC_MARVELL_BG4CD is not set # CONFIG_SOC_MEDIATEK_MT8173 is not set @@ -219,6 +220,7 @@ CONFIG_HEAP_SIZE=0xc0000 # CONFIG_SOC_NVIDIA_TEGRA210 is not set # CONFIG_SOC_QC_IPQ806X is not set # CONFIG_SOC_ROCKCHIP_RK3288 is not set +# CONFIG_SOC_ROCKCHIP_RK3399 is not set # CONFIG_CPU_SAMSUNG_EXYNOS5250 is not set # CONFIG_CPU_SAMSUNG_EXYNOS5420 is not set # CONFIG_SOC_UCB_RISCV is not set @@ -340,6 +342,7 @@ CONFIG_SUPERIO_WINBOND_W83667HG_A=y # # CONFIG_MAINBOARD_HAS_CHROMEOS is not set # CONFIG_UEFI_2_4_BINDING is not set +# CONFIG_USE_SIEMENS_HWILIB is not set # CONFIG_ARCH_ARM is not set # CONFIG_ARCH_BOOTBLOCK_ARM is not set # CONFIG_ARCH_VERSTAGE_ARM is not set @@ -400,8 +403,8 @@ CONFIG_HAVE_CMOS_DEFAULT=y CONFIG_CMOS_DEFAULT_FILE="src/mainboard/$(MAINBOARDDIR)/cmos.default" CONFIG_IOAPIC_INTERRUPTS_ON_FSB=y # CONFIG_IOAPIC_INTERRUPTS_ON_APIC_SERIAL_BUS is not set -# CONFIG_COMPILE_IN_DSDT is not set CONFIG_VERSTAGE_ADDR=0x2000000 +# CONFIG_POSTCAR_STAGE is not set # # Devices @@ -427,36 +430,16 @@ CONFIG_PCIEXP_CLK_PM=y CONFIG_PCIEXP_L1_SUB_STATE=y CONFIG_SUBSYSTEM_VENDOR_ID=0x0000 CONFIG_SUBSYSTEM_DEVICE_ID=0x0000 -# CONFIG_PXE_ROM is not set # CONFIG_SOFTWARE_I2C is not set # # Generic Drivers # # CONFIG_DRIVERS_AS3722_RTC is not set -CONFIG_DRIVERS_ASPEED_AST_COMMON=y -CONFIG_DEVICE_SPECIFIC_OPTIONS=y -CONFIG_DRIVERS_ASPEED_AST2050=y # CONFIG_ELOG is not set # CONFIG_GIC is not set -# CONFIG_SMBIOS_PROVIDED_BY_MOBO is not set -# CONFIG_DRIVERS_I2C_RTD2132 is not set -CONFIG_DRIVERS_I2C_W83795=y -# CONFIG_INTEL_DP is not set -# CONFIG_INTEL_DDI is not set -# CONFIG_INTEL_EDID is not set -# CONFIG_INTEL_INT15 is not set -# CONFIG_INTEL_GMA_ACPI is not set -# CONFIG_DRIVER_INTEL_I210 is not set # CONFIG_IPMI_KCS is not set # CONFIG_DRIVERS_LENOVO_WACOM is not set -# CONFIG_DRIVER_MAXIM_MAX77686 is not set -# CONFIG_DRIVER_PARADE_PS8625 is not set -# CONFIG_DRIVER_PARADE_PS8640 is not set -CONFIG_DRIVERS_MC146818=y -# CONFIG_MAINBOARD_HAS_LPC_TPM is not set -# CONFIG_DRIVERS_RICOH_RCE822 is not set -# CONFIG_DRIVERS_SIL_3114 is not set CONFIG_SPI_FLASH=y CONFIG_SPI_ATOMIC_SEQUENCING=y CONFIG_SPI_FLASH_MEMORY_MAPPED=y @@ -473,9 +456,6 @@ CONFIG_SPI_FLASH_STMICRO=y CONFIG_SPI_FLASH_WINBOND=y # CONFIG_SPI_FLASH_FAST_READ_DUAL_OUTPUT_3B is not set # CONFIG_HAVE_SPI_CONSOLE_SUPPORT is not set -# CONFIG_DRIVER_TI_TPS65090 is not set -# CONFIG_DRIVERS_TI_TPS65913 is not set -# CONFIG_DRIVERS_TI_TPS65913_RTC is not set CONFIG_DRIVERS_UART=y # CONFIG_NO_UART_ON_SUPERIO is not set # CONFIG_DRIVERS_UART_8250MEM is not set @@ -483,17 +463,32 @@ CONFIG_DRIVERS_UART=y # CONFIG_HAVE_UART_SPECIAL is not set # CONFIG_DRIVERS_UART_OXPCIE is not set # CONFIG_DRIVERS_UART_PL011 is not set -CONFIG_HAVE_USBDEBUG=n -CONFIG_HAVE_USBDEBUG_OPTIONS=n -CONFIG_USBDEBUG_IN_ROMSTAGE=n -CONFIG_USBDEBUG_DEFAULT_PORT=0 -# CONFIG_USBDEBUG_DONGLE_STD is not set -# CONFIG_USBDEBUG_DONGLE_BEAGLEBONE is not set -# CONFIG_USBDEBUG_DONGLE_BEAGLEBONE_BLACK is not set -# CONFIG_USBDEBUG_DONGLE_FTDI_FT232H is not set -CONFIG_USBDEBUG_OPTIONAL_HUB_PORT=0 +CONFIG_HAVE_USBDEBUG=y +CONFIG_HAVE_USBDEBUG_OPTIONS=y # CONFIG_DRIVER_XPOWERS_AXP209 is not set -CONFIG_RTC=y +CONFIG_DRIVERS_ASPEED_AST2050=y +CONFIG_DEVICE_SPECIFIC_OPTIONS=y +CONFIG_DRIVERS_ASPEED_AST_COMMON=y +# CONFIG_SMBIOS_PROVIDED_BY_MOBO is not set +# CONFIG_DRIVERS_I2C_RTD2132 is not set +CONFIG_DRIVERS_I2C_W83795=y +# CONFIG_INTEL_DP is not set +# CONFIG_INTEL_DDI is not set +# CONFIG_INTEL_EDID is not set +# CONFIG_INTEL_INT15 is not set +# CONFIG_INTEL_GMA_ACPI is not set +# CONFIG_DRIVER_INTEL_I210 is not set +# CONFIG_DRIVER_MAXIM_MAX77686 is not set +# CONFIG_DRIVER_PARADE_PS8625 is not set +# CONFIG_DRIVER_PARADE_PS8640 is not set +CONFIG_DRIVERS_MC146818=y +# CONFIG_MAINBOARD_HAS_LPC_TPM is not set +# CONFIG_DRIVERS_RICOH_RCE822 is not set +# CONFIG_DRIVERS_SIL_3114 is not set +# CONFIG_DRIVER_TI_TPS65090 is not set +# CONFIG_DRIVERS_TI_TPS65913 is not set +# CONFIG_DRIVERS_TI_TPS65913_RTC is not set +# CONFIG_RTC is not set # CONFIG_TPM is not set CONFIG_STACK_SIZE=0x1000 CONFIG_MMCONF_SUPPORT_DEFAULT=y @@ -523,9 +518,7 @@ CONFIG_CONSOLE_SERIAL_115200=y # CONFIG_CONSOLE_SERIAL_9600 is not set CONFIG_TTYS0_BAUD=115200 # CONFIG_SPKMODEM is not set -CONFIG_CONSOLE_USB=y # CONFIG_CONSOLE_NE2K is not set -CONFIG_CONSOLE_CBMEM=y CONFIG_CONSOLE_CBMEM_BUFFER_SIZE=0x20000 CONFIG_DEFAULT_CONSOLE_LOGLEVEL_8=y # CONFIG_DEFAULT_CONSOLE_LOGLEVEL_7 is not set @@ -537,7 +530,6 @@ CONFIG_DEFAULT_CONSOLE_LOGLEVEL_8=y # CONFIG_DEFAULT_CONSOLE_LOGLEVEL_1 is not set # CONFIG_DEFAULT_CONSOLE_LOGLEVEL_0 is not set # CONFIG_CMOS_POST is not set -CONFIG_CONSOLE_POST=y # CONFIG_NO_EARLY_BOOTBLOCK_POSTCODES is not set CONFIG_HAVE_ACPI_RESUME=y CONFIG_RESUME_PATH_SAME_AS_BOOT=y @@ -609,7 +601,6 @@ CONFIG_HAVE_DEBUG_SMBUS=y # CONFIG_DEBUG_MALLOC is not set # CONFIG_DEBUG_ACPI is not set # CONFIG_DEBUG_SPI_FLASH is not set -# CONFIG_DEBUG_USBDEBUG is not set # CONFIG_TRACE is not set CONFIG_ENABLE_APIC_EXT_ID=y CONFIG_WARNINGS_ARE_ERRORS=y diff --git a/resources/libreboot/config/seabios/kgpe-d16/config b/resources/libreboot/config/seabios/kgpe-d16/config @@ -166,16 +166,16 @@ CONFIG_RAMTOP=0x400000 CONFIG_CACHE_ROM_SIZE_OVERRIDE=0 CONFIG_CBFS_SIZE=0x200000 # CONFIG_POST_DEVICE is not set -CONFIG_USBDEBUG_HCD_INDEX=0 CONFIG_BOOT_MEDIA_SPI_BUS=0 CONFIG_TTYS0_LCS=3 +CONFIG_CONSOLE_POST=y +CONFIG_DRIVERS_UART_8250IO=y CONFIG_UDELAY_LAPIC_FIXED_FSB=200 CONFIG_CPU_ADDR_BITS=48 CONFIG_DEFAULT_CONSOLE_LOGLEVEL=8 # CONFIG_USBDEBUG is not set CONFIG_MAINBOARD_VERSION="1.0" CONFIG_DRIVERS_PS2_KEYBOARD=y -CONFIG_DRIVERS_UART_8250IO=y # CONFIG_NO_POST is not set CONFIG_BOARD_ROMSIZE_KB_2048=y # CONFIG_COREBOOT_ROMSIZE_KB_64 is not set @@ -211,6 +211,7 @@ CONFIG_BOOTBLOCK_SOUTHBRIDGE_INIT="southbridge/amd/sb700/bootblock.c" CONFIG_TTYS0_BASE=0x3f8 CONFIG_EHCI_BAR=0xfef00000 CONFIG_HEAP_SIZE=0xc0000 +CONFIG_CONSOLE_CBMEM=y # CONFIG_SOC_MARVELL_ARMADA38X is not set # CONFIG_SOC_MARVELL_BG4CD is not set # CONFIG_SOC_MEDIATEK_MT8173 is not set @@ -219,6 +220,7 @@ CONFIG_HEAP_SIZE=0xc0000 # CONFIG_SOC_NVIDIA_TEGRA210 is not set # CONFIG_SOC_QC_IPQ806X is not set # CONFIG_SOC_ROCKCHIP_RK3288 is not set +# CONFIG_SOC_ROCKCHIP_RK3399 is not set # CONFIG_CPU_SAMSUNG_EXYNOS5250 is not set # CONFIG_CPU_SAMSUNG_EXYNOS5420 is not set # CONFIG_SOC_UCB_RISCV is not set @@ -340,6 +342,7 @@ CONFIG_SUPERIO_WINBOND_W83667HG_A=y # # CONFIG_MAINBOARD_HAS_CHROMEOS is not set # CONFIG_UEFI_2_4_BINDING is not set +# CONFIG_USE_SIEMENS_HWILIB is not set # CONFIG_ARCH_ARM is not set # CONFIG_ARCH_BOOTBLOCK_ARM is not set # CONFIG_ARCH_VERSTAGE_ARM is not set @@ -400,8 +403,8 @@ CONFIG_HAVE_CMOS_DEFAULT=y CONFIG_CMOS_DEFAULT_FILE="src/mainboard/$(MAINBOARDDIR)/cmos.default" CONFIG_IOAPIC_INTERRUPTS_ON_FSB=y # CONFIG_IOAPIC_INTERRUPTS_ON_APIC_SERIAL_BUS is not set -# CONFIG_COMPILE_IN_DSDT is not set CONFIG_VERSTAGE_ADDR=0x2000000 +# CONFIG_POSTCAR_STAGE is not set # # Devices @@ -427,36 +430,16 @@ CONFIG_PCIEXP_CLK_PM=y CONFIG_PCIEXP_L1_SUB_STATE=y CONFIG_SUBSYSTEM_VENDOR_ID=0x0000 CONFIG_SUBSYSTEM_DEVICE_ID=0x0000 -# CONFIG_PXE_ROM is not set # CONFIG_SOFTWARE_I2C is not set # # Generic Drivers # # CONFIG_DRIVERS_AS3722_RTC is not set -CONFIG_DRIVERS_ASPEED_AST_COMMON=y -CONFIG_DEVICE_SPECIFIC_OPTIONS=y -CONFIG_DRIVERS_ASPEED_AST2050=y # CONFIG_ELOG is not set # CONFIG_GIC is not set -# CONFIG_SMBIOS_PROVIDED_BY_MOBO is not set -# CONFIG_DRIVERS_I2C_RTD2132 is not set -CONFIG_DRIVERS_I2C_W83795=y -# CONFIG_INTEL_DP is not set -# CONFIG_INTEL_DDI is not set -# CONFIG_INTEL_EDID is not set -# CONFIG_INTEL_INT15 is not set -# CONFIG_INTEL_GMA_ACPI is not set -# CONFIG_DRIVER_INTEL_I210 is not set # CONFIG_IPMI_KCS is not set # CONFIG_DRIVERS_LENOVO_WACOM is not set -# CONFIG_DRIVER_MAXIM_MAX77686 is not set -# CONFIG_DRIVER_PARADE_PS8625 is not set -# CONFIG_DRIVER_PARADE_PS8640 is not set -CONFIG_DRIVERS_MC146818=y -# CONFIG_MAINBOARD_HAS_LPC_TPM is not set -# CONFIG_DRIVERS_RICOH_RCE822 is not set -# CONFIG_DRIVERS_SIL_3114 is not set CONFIG_SPI_FLASH=y CONFIG_SPI_ATOMIC_SEQUENCING=y CONFIG_SPI_FLASH_MEMORY_MAPPED=y @@ -473,9 +456,6 @@ CONFIG_SPI_FLASH_STMICRO=y CONFIG_SPI_FLASH_WINBOND=y # CONFIG_SPI_FLASH_FAST_READ_DUAL_OUTPUT_3B is not set # CONFIG_HAVE_SPI_CONSOLE_SUPPORT is not set -# CONFIG_DRIVER_TI_TPS65090 is not set -# CONFIG_DRIVERS_TI_TPS65913 is not set -# CONFIG_DRIVERS_TI_TPS65913_RTC is not set CONFIG_DRIVERS_UART=y # CONFIG_NO_UART_ON_SUPERIO is not set # CONFIG_DRIVERS_UART_8250MEM is not set @@ -483,17 +463,32 @@ CONFIG_DRIVERS_UART=y # CONFIG_HAVE_UART_SPECIAL is not set # CONFIG_DRIVERS_UART_OXPCIE is not set # CONFIG_DRIVERS_UART_PL011 is not set -CONFIG_HAVE_USBDEBUG=n -CONFIG_HAVE_USBDEBUG_OPTIONS=n -CONFIG_USBDEBUG_IN_ROMSTAGE=n -CONFIG_USBDEBUG_DEFAULT_PORT=0 -# CONFIG_USBDEBUG_DONGLE_STD is not set -# CONFIG_USBDEBUG_DONGLE_BEAGLEBONE is not set -# CONFIG_USBDEBUG_DONGLE_BEAGLEBONE_BLACK is not set -# CONFIG_USBDEBUG_DONGLE_FTDI_FT232H is not set -CONFIG_USBDEBUG_OPTIONAL_HUB_PORT=0 +CONFIG_HAVE_USBDEBUG=y +CONFIG_HAVE_USBDEBUG_OPTIONS=y # CONFIG_DRIVER_XPOWERS_AXP209 is not set -CONFIG_RTC=y +CONFIG_DRIVERS_ASPEED_AST2050=y +CONFIG_DEVICE_SPECIFIC_OPTIONS=y +CONFIG_DRIVERS_ASPEED_AST_COMMON=y +# CONFIG_SMBIOS_PROVIDED_BY_MOBO is not set +# CONFIG_DRIVERS_I2C_RTD2132 is not set +CONFIG_DRIVERS_I2C_W83795=y +# CONFIG_INTEL_DP is not set +# CONFIG_INTEL_DDI is not set +# CONFIG_INTEL_EDID is not set +# CONFIG_INTEL_INT15 is not set +# CONFIG_INTEL_GMA_ACPI is not set +# CONFIG_DRIVER_INTEL_I210 is not set +# CONFIG_DRIVER_MAXIM_MAX77686 is not set +# CONFIG_DRIVER_PARADE_PS8625 is not set +# CONFIG_DRIVER_PARADE_PS8640 is not set +CONFIG_DRIVERS_MC146818=y +# CONFIG_MAINBOARD_HAS_LPC_TPM is not set +# CONFIG_DRIVERS_RICOH_RCE822 is not set +# CONFIG_DRIVERS_SIL_3114 is not set +# CONFIG_DRIVER_TI_TPS65090 is not set +# CONFIG_DRIVERS_TI_TPS65913 is not set +# CONFIG_DRIVERS_TI_TPS65913_RTC is not set +# CONFIG_RTC is not set # CONFIG_TPM is not set CONFIG_STACK_SIZE=0x1000 CONFIG_MMCONF_SUPPORT_DEFAULT=y @@ -523,9 +518,7 @@ CONFIG_CONSOLE_SERIAL_115200=y # CONFIG_CONSOLE_SERIAL_9600 is not set CONFIG_TTYS0_BAUD=115200 # CONFIG_SPKMODEM is not set -CONFIG_CONSOLE_USB=y # CONFIG_CONSOLE_NE2K is not set -CONFIG_CONSOLE_CBMEM=y CONFIG_CONSOLE_CBMEM_BUFFER_SIZE=0x20000 CONFIG_DEFAULT_CONSOLE_LOGLEVEL_8=y # CONFIG_DEFAULT_CONSOLE_LOGLEVEL_7 is not set @@ -537,7 +530,6 @@ CONFIG_DEFAULT_CONSOLE_LOGLEVEL_8=y # CONFIG_DEFAULT_CONSOLE_LOGLEVEL_1 is not set # CONFIG_DEFAULT_CONSOLE_LOGLEVEL_0 is not set # CONFIG_CMOS_POST is not set -CONFIG_CONSOLE_POST=y # CONFIG_NO_EARLY_BOOTBLOCK_POSTCODES is not set CONFIG_HAVE_ACPI_RESUME=y CONFIG_RESUME_PATH_SAME_AS_BOOT=y @@ -609,7 +601,6 @@ CONFIG_HAVE_DEBUG_SMBUS=y # CONFIG_DEBUG_MALLOC is not set # CONFIG_DEBUG_ACPI is not set # CONFIG_DEBUG_SPI_FLASH is not set -# CONFIG_DEBUG_USBDEBUG is not set # CONFIG_TRACE is not set CONFIG_ENABLE_APIC_EXT_ID=y CONFIG_WARNINGS_ARE_ERRORS=y